Opticentre

Frequently Asked Questions

Heartsome

Heartsome Truly and completely cross platform, supportive of all key industry standards, namely XLIFF, TMX, TBX, Unlimited support for languages


What does it take in terms of minimal requirements to run Heartsome?

Heartsome's products are all dependent on the use of a recent version of Java Runtime (at least Version 1.4.2) together with a highly efficient database. These are applications that will only thrive in computer systems equipped with a relatively large RAM, at least 512KB for those running the server version and 256KB for those running the client version.

Read more

What are the most unique features in Heartsomes translation tools?

We consider ourselves the most unique in the light of the following:

Read more

What kind of IT platform do I need to run Heartsomes translation tools?

The basic requirements are:

Read more

The editor I have just installed does not start. What can I do?

Ensure that you have correctly installed Java 1.4.x and that a JVM is in your path.

Read more

I am trying to use a Macintosh or Linux version of the Heartsome editor to translate an Arabic document, but it does not seem to work properly?

Bi-directional languages are currently supported on Microsoft Windows only because the technology foundation of Heartsome's tools, Eclipse SWT, has yet to implement support for bidirectional languages in any other platform.

Read more

Our problem in using your product in Windows is the regular recurrence of: unknown protocol: c error. Do you have a solution?

This problem is unique to Windows 2000 users on their trying to run Java applications. It normally affects those who have failed to faithfully update their Windows operating systems. This applies as well to those using Microsoft Office software failing to update with patches and bug fixes made available by Microsoft. In simple language, it is caused by the existence of one or more empty spaces in the directory name (path to a file). There are two ways to resolve the problem:

  • Do not allow empty spaces in names of folders, directories and files. For example, working with a file from "c:\Documents and Settings" where there are two empty spaces in the directory name will surely crash the Heartsome editor or any other Java applications in use.
  • Ensure that you are using genuine copies, whether Microsoft Windows 2000 or Microsoft Office or both; and be sure as well that you have installed all their updates, patches and fixes which have been made available over the years.

Read more

Are Heartsomes Translation Memories compatible with other CAT tools?

Heartsome's tools are wholly compliant with TMX 1.1, 1.2, 1.3 and 1.4 at Levels 1 and 2.

Read more

Can we assume that Heartsomes translation tools work with any XML DTD?

Yes, Heartsome's tools include XML catalogue management. Our tools and provide configuration options for converting, aligning and extracting terms from any XML document accompanied with a DTD.

Read more

What is the translation memory technology of Heartsome?

The technology that underlines the foundation of Heartsome's Translation tools is known as "translation memory" (TM). It is a language technology that enables the translation of segments (paragraphs, sentences or phrases) of documents by searching for similar segments in a database and suggesting matches that are found in the database as possible translations. It may further suggest several translations for a paragraph, a sentence or a phrase.

Read more

Improving speed of TMX imports?

Three factors are relevant when importing a TMX file into a database. They are:

Read more

Reorganizing TMX files with 3 or more languages?

If you have a TMX document with 3 or more languages that looks like this:

EN
ES
FR
Good evening
Buenas noches

Read more

Installation of Aspell spell checker on Windows?

Here is a short recipe for installing Aspell on Windows:

  • 1. Download Aspell and dictionaries for Windows from here.
  • 2. Install Aspell and the dictionaries in the default directories offered by the installers.
  • 3. Start XLIFF Editor.
  • 4. Select Aspell as default spell checker using the Default Spell Checker option in

    Read more

    Installing and configuring Aspell on MacOS X?

    Since, unlike Linux users, Mac users often have little experience with a command-line interface, below is a step-by-step approach to installing Aspell for use with the Heartsome suite.

    • 0. There is a thing called cocoAspell, which is an Aspell implementation for OS X. THIS IS NOT WHAT YOU WANT.
    • 1. Download Fink from http://fink.sourceforge.net/. Fink is a package which enables you to install Unix software on our Mac without getting your fingers dirty For step-by-step instructions using DarwinPorts instead of Fink to install and configure Aspell through the Mac OS X Terminal, see the following section.
    • 2. Once the disk image is mounted, double click on "Fink x.x.x Installer.pkg" to run the installation. You will need to type in a user password with Admin privileges once (and maybe twice).
    • 3. Once installation is finished, copy the "Fink Commander" folder from the disk image to your Applications folder. You need to do this because: (i) it won't work properly if run off a disk image; (ii) you may want to use it again to install more Open Source software in the future.
    • 4. In your Applications folder, open the Fink Commander folder and launch the Fink Commander application.
    • 5. When Fink Commander has finished launching and updating its database, you will see a window with a list of stuff in the top half and an empty bottom half. In the top half, click on the heading of the "Name" column to sort by name. Then scroll down until you see Aspell and friends (which are the language dictionaries: aspell-de, aspell-en, aspell-es, etc.). The column immediately to the right is called "Installed". If it is empty, that means the item has not been installed. If it contains a number or something, that means the particular item has been installed and the number is the version number. You will most likely see that neither "aspell" nor any of its language dictionaries are installed.
    • 6. First, double click on the "aspell" line and Fink Commander will connect to the Internet to download the necessary files. Again, you may be asked for password with Admin privileges.
    • 7. Once Aspell is succesfully installed, double click on one of the language dictionaries (for example, "aspell-en" and go through the same process as in point 6).
    • 8. When you have installed all the dictionaries you want, quit Fink Commander.
    • 9. Now you have tell Heartsome where Aspell is and how to use it. Switch to (or launch) XLFedit and pull down the Options menu; set Aspell as default engine in the Default Spell Checker option and then choose Aspell Dictionaries in the Options menu to display the configuration dialog.
    • 10. In the box called "Aspell Command", type "/sw/bin/aspell" (that's where Fink installed your Aspell package). You could also get this by clicking the "Browse" button and navigating down from the top of your hard disk (Macintosh HD or whatever you called it) through the "sw" folder to the "bin" folder and then choosing "aspell".
    • 11. Now, under "Default dictionary", pull down the menu and choose one of the installed language dictionaries. Then, on the left-hand side, under "Language", choose the language that dictionary corresponds to. Note that this must match the Language codes you work with in Heartsome. Then click the arrow between the two and you will find that pair of language and dictionary has been added to the window below. Continue this until you have added all the language dictionaries you wish to use. Click "Save" and you are ready to go.

    Read more

    I get an error about Java not being installed, what does that mean?

    All Heartsome's tools require Java 1.5 or better. You can download Java for free here.

    Read more

    Can Oracle 9i be used with Heartsome tools?

    Heartsome Translation Suite works OK with Oracle 9.2.

    Read more

    What document formats are supported by the XLIFF Translation Editor?

    Heartsome's XLIFF Translation Editor supports these formats:

Interested in our full range of services and solutions?

Our Clients